Sunday, October 19, 2014

Android L (API 21) - java.lang.IllegalArgumentException: Service Intent must be explicit

Android new version - "Lollipop" (API 21) brings quite a few changes with it, but it comes with some price if you wish to target your app to that API.

When we started adapting our apps to the new API, one of the first problems we've encountered is the `IllegalArgumentException: Service Intent must be explicit`



If you have encountered the problem, and you are actually intending to use your intent in explicit way (meaning that when starting the service you are expecting to hit exactly 1 service action), here's a quick fix for turning implicit --> explicit:
That should do it. Please feel free to comment for additional insights on this new issue.